Incompatibility Flashbuilder 4.1 Eclipse Plugin and Eclipse Helios

Today I discoverd a strange bug in Flashbuilder 4.1 Eclipse plugin in combination with Eclipse Helios SR1.

The installation was without problems and I was even able to run FlexUnit testcases for Flex Application projects but I wasn’t able to run FlexUnit testcases for Flex Library projects. I always got this error:

FlexUnitApplication start failed. Reason: Local configuration cannot be nested in a directory.

First of all I thought my testcases were damaged. I thought false because I was able to run the testcases successfully using the maven command “mvn test”.

Then I suspected flexmojos 3.6.1 to destroy the project setup. I was false again because when I launched the Flashbuilder standalone I was able to run the testcases in the library project.

The Flashbuilder standalone version uses Eclipse Galileo instead of Eclipse Helios.

So if anybody out there has the same problem: the reason is a incompatibility between Flashbuilder 4.1 Eclipse plugin and Eclipse Helios.

Advertisements

2 thoughts on “Incompatibility Flashbuilder 4.1 Eclipse Plugin and Eclipse Helios

    1. Fortunately Flashbuilder Burrito ( FlashBuilder 4.5 beta) can be used as Helios Plugin. After installing the Burrito standalone version you can find a utilities folder in the Burrito program folder.
      Run FB_Burrito_Plugin_Utility.exe, give the Burrito folder and your Eclipse Helios folder. After that you can use FlashBuilder 4.5 beta in Eclipse Helios.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s